Autor Thema: Windows7 64bit und BU0836  (Gelesen 3644 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline 88.IAP_Andre

  • Flugschüler
  • ***
  • Beiträge: 112
Windows7 64bit und BU0836
« am: 14.Mai.2011, 16:18 »
Beim anschliessen der Gamecontroller an den neuen Rechner tauch wieder mal ein Problem auf  ???.
Erfolgreich erkannt wurden MS FFB2 (kein Treiber installiert); Saitek X45 und Pedale (Treiber für Win7 64bit wurde installiert).
Für den BU0836 brauch man ja keine Treiber. Er wird auch unter Systemsteuerung->Hardware und Sound->Geräte und Drucker als Gamecontroller angezeigt aber taucht unter "Gamecontrollereinstellungen" nicht mit auf. Bei DIView wird er auch nicht erkannt.  :'( Ach ja beim alten Rechner wurde er bis zum Schluss erkannt.
Hatt jemand ne Idee ?

Gruß Andre

Offline usrusr

  • Blasenteetrinker
  • *****
  • Beiträge: 824
Re: Windows7 64bit und BU0836
« Antwort #1 am: 14.Mai.2011, 18:49 »
Idee habe ich leider keine, aber zumindest kann ich bestätigen, dass ein BU0836A bei mir erfolgreich (und ohne besondere Tricks) mit Win 7 64 bit spricht. Vielleicht hilft dir diese Info ja dabei, in der richtigen Ecke nach der Fehlerursache zu stöbern.

Offline 88.IAP_Andre

  • Flugschüler
  • ***
  • Beiträge: 112
Re: Windows7 64bit und BU0836
« Antwort #2 am: 14.Mai.2011, 19:53 »
Hm hab keinen richtigen Plan wo ich suchen soll.
Erst mal wie bekomm ich den BU0836 aus der registry (wenn er da denn drin steht)?

Offline FG28_Kodiak

  • Blasenteetrinker
  • *****
  • Beiträge: 1.893
Re: Windows7 64bit und BU0836
« Antwort #3 am: 14.Mai.2011, 20:49 »
Wenn du bei Geräte und Drucker den BU mit der rechten Maustaste anklickst und auf Gamecontrollereinstellungen gehst, kommt da kein Dialog zum Einstellen?

Offline 88.IAP_Andre

  • Flugschüler
  • ***
  • Beiträge: 112
Re: Windows7 64bit und BU0836
« Antwort #4 am: 14.Mai.2011, 20:57 »
Hier mal zur Verdeutlichung:


Was habt ihr denn für Mainboards ?

Beim P67 Chipsatz soll es Probleme mit der USB-Erkennung geben.

Offline usrusr

  • Blasenteetrinker
  • *****
  • Beiträge: 824
Re: Windows7 64bit und BU0836
« Antwort #5 am: 15.Mai.2011, 03:14 »
Wie weit hast du die Hardwareaspekte schon durchgeklappert? Also Kabel noch mal neu verbinden, vielleicht mal ein anderer Anschluss und so weiter?

Wie schaut es im Gerätemanager unter "Eingabegeräte (Human Interface Devices)" aus? Die Bodnar-Unit sollte da sowohl als "USB-Eingabegerät" erscheinen als auch als "HID-konformer Gamecontroller", und das natürlich ohne gelbes Ausrufezeichen. Da dieser Bereich bei einem typischen Simmer ja eher überbevölkert ist (auch Mäuse und USB-Tastaturen tauchen hier doppelt auf, dazu virtuelle Eingabegeräte aus denen die virtuellen Tastenereignisse aus diversen "Profiler"-Anwendungen kommen), aber über "Hardware-IDs" unter Eigenschaften->Details sollte man die BU an der Vendor-ID (HID\VID_16C0&PID...), die, wenn ich mich recht erinnere diejenige von V-USB ist (das quasi das "Betriebssystem", das auf dem Controller läuft).

Zum Bild: du schreibst was von FFB2, X45 und Saitek-Pedalen. Alle drei sind im Screenshot abgebildet, dazu aber noch ein viertes "Generic USB Device". Was ist das für eins?

Offline 88.IAP_Andre

  • Flugschüler
  • ***
  • Beiträge: 112
Re: Windows7 64bit und BU0836
« Antwort #6 am: 15.Mai.2011, 09:51 »
Der BU erscheint bei "Eingabegeräte HID" sowohl als "USB-Eingabegerät" als auch als "HID-konformer Gamecontroller",
Zur Ventor ID:


Der "Genergic USB Joystick" ist ein umgebautes Gamepad: http://forum.88-iap.de/viewtopic.php?t=817
Wobei ich hier schon das nächste Problem auf mich zukommen seh. Der hat sich in der Liste vor den MS FFB2 geschoben. Bei XP war es so das nur der Erste in der Liste die FFB-Effekte bekommen hat.

Heute hab ich mal das Mjoy8 aus dem Keller geholt und zu Testzwecken angesteckt, es funktioniert.

Zurück zum BU. Das mit den USB-Anschlüssen am Mainboard kann ich auch ausschließen, hab den BU an einer PCIe zu USB Karte geteste, das gleich Bild. Ehrlich gesagt weis ich nicht so recht weiter. Vielleicht werd ich mir nen neuen BU0836A holen, so zum testen.

Offline JG333_Adam

  • Hallenfeger
  • **
  • Beiträge: 37
Re: Windows7 64bit und BU0836
« Antwort #7 am: 15.Mai.2011, 11:54 »
Hi Andre,
bei mir wird er als BU0836 Interface und nicht als A/D Controller BU0836 erkannt und funktioniert mit W7(32)
Was passiert wenn Du nur den Controller allein anschließt? Wird auch nicht angezeigt?
System: i5 2500K 3,3Ghz 4GB Corsair DDR3
Asus GTX 560 Ti Win7 32Bit 1TB WD 5400 rpm

Offline usrusr

  • Blasenteetrinker
  • *****
  • Beiträge: 824
Re: Windows7 64bit und BU0836
« Antwort #8 am: 15.Mai.2011, 13:32 »
Meine BU036A hat PID 05BA ("Product ID", hexadezimal sind das 5 über deinem 05B5) und REV 120 (hexadezimal oder nicht, es ist etwas höher, hat aber über PID-Grenzen hinweg wahrscheinlich gar nichts zu bedeuten). Da die Vendor-ID (VID) nicht Leo Bodnar persönlich ist, sondern V-USB, von denen Leo neben der Software auch einzelne PIDs für seine unterschiedlichen Produkte lizensiert (eine "echte" eigene VID gibt es erst ab 2000$ Registrierungsgebühr). Die Product-ID unterscheidet nicht nur zwischen verschiedenen Leo-Bodnar-Produkten sondern auch zwischen denen anderer V-USB-Lizenznehmer, deshalb ist ein Schritt von 5 in der PID eher klein. Was hat das mit dem konkreten Problem oder gar einer Lösung zu tun? Relativ wenig, aber zu viel Hintergrundwissen kann man gar nicht haben.

Zurück zum Thema: aus Google purzeln ein paar wage Hinweise darauf, dass ältere Firmwareversionen und Vista/7 nicht so recht zusammenkommen:

http://forums.ubi.com/eve/forums/a/tpc/f/49310655/m/4061062608?r=5941088608#5941088608

Schade, dass das Forum auf www.leobodnar.com nicht mehr läuft. Das wäre jetzt die passende Anlaufstelle. So musst du ihn wohl direkt anschreiben, kannst ja mal fragen ob er den alten Chip hochflasht, wenn du gleichzeitig eine 836a oder 836x dazubestellst, davon kann man ja nie genug im Haus haben ;)