Autor Thema: Conf.ini setzt Hardwareshader auf 0 zurück (Laptop Acer Aspire ES1-111-C5M1)  (Gelesen 2091 mal)

0 Mitglieder und 1 Gast betrachten dieses Thema.

Offline Waggelchen

  • Hallenfeger
  • **
  • Beiträge: 29
Guten Tag

Hab mir einen neuen Laptop gekauft und habe mir Sturmovik wieder installiert (Derzeit 4.12m ...)
Die Installation lief soweit problemlos.

Von Sturmovik 1946 DVD gepatcht auf 4.12. Zwischendurch Simulation immer wieder gestartet und geschaut ob alles funktioniert.

Nun bin ich bei 4.12 angekommen und fing an, die Conf.ini zu bearbeiten mit Hilfe des Sturmowiki Artikels.

Mein Problem ist, dass im Bereich der Open GL Settings die Konfiguration des Harwareshaders von 0 auf 1 nicht gespeichert wird.

Kein Glitzerwasser und die Bäume sehen aus  wie ...  :-[

Mein Laptop ist ein nagelneuer Acer Aspire ES1-111-C5M1 mit Windows 8.1 als Betriebssystem

Prozessor ist ein Intel Celeron CPU N2940 mit  1.84GHz (Anscheinend sind da 4 Stück von drin)
Installierter Arbeitsspeicher: 2GB
Grafikkarte ist eine Intel HD Graphics. (mehr Infos konnte ich noch nicht ergattern)

Bin grad ein wenig sprachlos.

Gruß an die Il-2 Familie

Waggel

P.S.: Folgendes gefunden: http://forum.1cpublishing.eu/showthread.php?t=29761

Intel HD Grakas für Laptops sind für Sturmovik anscheinend suboptimal. Ich werde mal weiter recherchieren.



« Letzte Änderung: 03.Juli.2015, 18:07 von Waggelchen »

Offline Airway

  • Blasenteetrinker
  • *****
  • Beiträge: 2.112
Conf.ini bearbeiten?

Das machen wir aber schon lange nicht mehr. Alle Optionen sind mittlerweile im Spiel einzustellen  :)

Aber Du hast schon erkannt. Die Spezifikationen Deines Netbooks werden heute von den meisten Smartphones übertroffen.
Onboard Grafikkarte und CPU, sowie der geringe Arbeitsspeicher ziehen allesamt die Wurst nicht vom Teller, in heutigen Zeiten.

Ich hatte seinerzeit auf meinem Asus Netbook auch mal Il-2 am laufen, aber das war auch eher an der Grenze des machbaren für das kleine Teil.
Sofern Du den Arbeitsspeicher in Deinem Gerät verdoppeln kannst, würde das vielleicht etwas bei der Performance helfen.
Dann checken ob Du DirectX, Java und die neusten Treiber für Dein Gerät installiert hast. Viel mehr wird nicht gehen.

Wenn Du eine alte Installation einfach auf Deinen neuen Rechner gezogen hast, kannst Du maximal in der conf.ini schauen, was da im Abschnitt [open_gl]
bei "VideoSetupId" eingetragen ist. Eine 17 ermöglicht das Verändern der anderen Optionen.

Kannt Deine conf.ini aber auch mal gerne zum drüber schauen mal posten .

Gruß,
Airway

Offline Waggelchen

  • Hallenfeger
  • **
  • Beiträge: 29
Hallo Airway

Erst einmal Danke für die Antwort.

Ich hab mal Windows-Taste+r gedrückt und "dxdiag" in das Eingabefeld eingegeben.

Hier sind noch zusätzliche Informationen, die ich gefunden habe.

System läuft mit Direct X 11. Sollte also auf dem neusten Stand sein.

Die Grafikkarte (Chiptyp Intel  HD Graphics) hat einen Speicher von 1 GB (996MB) und einen Anzeigemodus von 1366x768 Pixel bei 32 Bit und 60 HZ.

Also die Grafik läuft wie geschmiert. Flüssig und selbst das Black Death Referenzvideo läuft ohne Lags.

Die 2 GB Arbeitsspeicher sind nicht sonderlich viel weil ja schon Windows 8 viel Speicher braucht, jedoch wenn man den ganzen Schnick Schnack im Task Manager ausschaltet, hat man wieder mehr als genug.

"VideoSetupId" habe ich auf 17 gestellt.

Zitat
Kannt Deine conf.ini aber auch mal gerne zum drüber schauen mal posten .

Meine Conf.ini schaut so aus:

Zitat
[il2]
title=Il2-Sturmovik Forgotten Battles
hotkeys=HotKey game

[window]
width=1366
height=768
ColourBits=32
DepthBits=24
StencilBits=8
ChangeScreenRes=1
FullScreen=1
DrawIfNotFocused=0
EnableResize=0
EnableClose=1
SaveAspect=0
Use3Renders=0
WideScreenFoV=1
UIColor=1
UIDetail=4
UIBackground=de

[GLPROVIDER]
GL=Opengl32.dll

[GLPROVIDERS]
Open GL=Opengl32.dll
DirectX=dx8wrap.dll

[NET]
speed=10000
routeChannels=0
serverChannels=31
localPort=21000
remotePort=21000
SkinDownload=1
serverName=No Name
serverDescription=
remoteHost=
localHost=
socksHost=
checkServerTimeSpeed=1
checkClientTimeSpeed=0
disableNetStatStatistics=0
showPilotNumber=1
showPilotPing=1
showPilotName=1
showPilotScore=1
showTeamScore=0
cumulativeTeamScore=0
showPilotArmy=1
showPilotACDesignation=1
showPilotACType=1
filterUserNames=0
reflyKIADelay=0
maxAllowedKIA=-1
reflyKIADelayMultiplier=0.0
reflyDisabled=0
allowMorseAsText=1
allowCustomSounds=1

[MaxLag]
farMaxLagTime=10.0
nearMaxLagTime=2.0
cheaterWarningDelay=5.0
cheaterWarningNum=-1

[chat]
region=(dx=0.6925,dy=0.071666665,x=0.0,y=0.0)

[game]
Arcade=0
HighGore=0
mapPadX=0.6689453
mapPadY=-0.046875
viewSet=34
Intro=0
NoSubTitles=0
NoChatter=0
NoHudLog=0
NoLensFlare=0
iconTypes=3
eventlog=eventlog.lst
eventlogkeep=0
3dgunners=1
ScreenshotType=0
RecordingIndicator=0
MapAlpha=0.34
SaveTrk=1
SkipParatrooperViews=0
NoMissionInfoHud=0
noKillInfoHud=0
BlockMorseChat=0
SmallMapWPLabels=1
ShowMorseAsText=0


[HotKey game]
PrintScreen=ScreenShot
P=pause
Pause=pause

[HotKey gui]
Escape=activate

[HookViewFly Config]
timeFirstStep=2.0
deltaZ=10.0

[HookView]
MouseLeft=Len

[HookView Config]
AzimutSpeed=0.1
TangageSpeed=0.1
LenSpeed=1.0
MinLen=1.0
DefaultLen=20.0
MaxLen=3000.0
Speed=6
LeanF=0.089999996
LeanS=0.089999996
Raise=0.04
RubberBand=0.01

[HotKey builder]
MouseLeft=objectMove
MouseRight=popupmenu
Enter=freeView
Shift MouseLeft=worldZoom
Alt MouseLeft=select+
Alt MouseRight=select-
Alt Ctrl=unselect
PageDown=change+
PageUp=change-
End=change++
Home=change--
Ctrl MouseLeft=insert+
Insert=insert+
NumPad-0=insert+
F=fill
Ctrl MouseRight=delete+
NumPad.=delete+
Delete=delete+
Backspace=cursor
Tab=cursor
F10=land
F11=onLand
NumPad-=normalLand
NumPad+=toLand
NumPad-5=resetAngles
NumPad-8=resetTangage90
NumPad-7=stepAzimut-5
NumPad-4=stepAzimut-15
NumPad-1=stepAzimut-30
NumPad-9=stepAzimut5
NumPad-6=stepAzimut15
NumPad-3=stepAzimut30

[MouseXYZ]
F1=SpeedSlow
F2=SpeedNormal
F3=SpeedFast
MouseRight=XYmove
F4 MouseRight=Zmove
MouseMiddle=Amove
F5 MouseRight=Amove
F6 MouseRight=Tmove
F7 MouseRight=Kmove

[MouseXYZ Config]
RealTime=1

[HotKey Console]
Shift Tab=Activate
[Console]
HISTORY=1024
HISTORYCMD=1024
LOAD=console.cmd
SAVE=console.cmd
LOG=0
LOGTIME=0
LOGFILE=log.lst
LOGKEEP=0

[sound]
SoundUse=1
SoundEngine=1
Speakers=1
Placement=0
SoundFlags.reversestereo=0
RadioFlags.Enabled=0
RadioEngine=2
MusicVolume=1
ObjectVolume=14
MusState.takeoff=0
MusState.inflight=0
MusState.crash=0
MusFlags.play=0
MasterVolume=6
Attenuation=7
SoundMode=2
SamplingRate=2
NumChannels=3
SoundExt.occlusions=0
SoundFlags.hardware=1
SoundFlags.streams=1
SoundFlags.duplex=1
SoundExt.acoustics=0
SoundExt.volumefx=0
SoundFlags.voicemgr=0
SoundFlags.static=1
VoiceVolume=12
Channels=2
SoundExt.extrender=0
SoundFlags.bugscorrect=0
SoundSetupId=8
ActivationLevel=0.02
Preemphasis=0.85
RadioLatency=0.5
AGC=1
PTTMode=1
SoundFlags.UseRadioChatter=0
SoundFlags.AutoActivation=0
RadioFlags.PTTMode=0
RadioFlags.PlayClicks=0
ActLevel=1
MicLevel=0
SoundFlags.forceEAX1=0

[rts]
;ProcessAffinityMask=1
mouseUse=2
joyUse=1
trackIRUse=1
DisableIME=0
locale=de
JoyProfile=0
UseSmartAxis=0

[rts_mouse]
SensitivityX=1.0
SensitivityY=1.0
Invert=0
SensitivityZ=1.0

[rts_joystick]
X=0 1 4 9 16 25 36 49 64 81 100 0
Y=0 1 4 9 16 25 36 49 64 81 100 0
Z=0 10 20 30 40 50 60 70 80 90 100
RZ=0 10 20 30 40 50 60 70 80 90 100 0
FF=0
U=0 10 20 30 40 50 60 70 80 90 100 0
V=0 10 20 30 40 50 60 70 80 90 100 0

[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=0
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=1

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=4
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=2
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1

TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=0

Shadows=1
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=1
Forest=1
LandShading=1
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=2
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

Offline Airway

  • Blasenteetrinker
  • *****
  • Beiträge: 2.112


[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=0
TexFlags.TexCompressARBExt=0


TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1

HardwareShaders=1

Shadows=1
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3

LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
Water=2
Effects=1
ForceShaders1x=0

PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0

Das sind die Unterschiede zu meiner conf.ini.

Offline Waggelchen

  • Hallenfeger
  • **
  • Beiträge: 29
Hallo Airway

Werde Deine Config mal übernehmen und bei mir prüfen. Habe heute schon Joystick, Schubregler und Pedale angeschlossen. Entsprechende aktuelle Treiber besorgt und alles konfiguriert. Läuft.

Jetzt kann ich mich erst mal wieder der Grafik widmen.

Offline Waggelchen

  • Hallenfeger
  • **
  • Beiträge: 29
Ich habe an der Conf.ini ein wenig herum getüftelt und die Angaben von Airway übernommen. Schaut schon besser aus.
Was ich immer noch nicht weg bekommen habe sind die Grafikfehler in den Wolken und der Hardwareshader stellt sich hin und wieder auf 0 zurück.


Hat jemand so ein Problem schon gehabt und konnte es lösen?

Offline Airway

  • Blasenteetrinker
  • *****
  • Beiträge: 2.112
Hab ich noch nie gesehen. Kannst Du Grafikeinstellungen im Betriebssystem einstellen?

Offline Waggelchen

  • Hallenfeger
  • **
  • Beiträge: 29
Ja, ich kann die Grafikeinstellungen im Betriebssystem ändern. Habe da aber noch nichts eingestellt. Alles Werkseinstellung. Im Anhang ist ein Screenshot von den Einstellmöglichkeiten.

Offline Airway

  • Blasenteetrinker
  • *****
  • Beiträge: 2.112
Hm. Keine Auffäligkeiten  :-X

Offline Waggelchen

  • Hallenfeger
  • **
  • Beiträge: 29
Ich habs!!!  :o

 ;D

Habe Sturmovik noch einmal gestartet. Bin dann bei den Grafikoptionen umgestiegen von Open GL auf Direct X. Und nun ist der Grafikbug in den Wolken weg. Die sehen jetzt richtig toll aus. Antialiasing habe ich ausgeschaltet und den Anisotropischen Filter habe ich auf 4 gesetzt. Jetzt werde ich mir mal eine FPS Anzeige organisieren und ein wenig feinoptimieren für Onlineeinsätze.

Zitat
[Render_DirectX]
TexQual=3
TexMipFilter=2
TexCompress=2
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=1
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=0
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=0
TexFlags.SeparateSpecular=0
TexFlags.TextureShaderNV=0

HardwareShaders=0

Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3

Sky=2
Forest=2
LandShading=3
LandDetails=2

LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1

VideoSetupId=17
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
Water=1
Effects=1

Das sind meine Einstellungen für Direct X. Komischerweise hat sich bei der Umstellung der Hardwareshader im Bereich Direct X wieder auf 0 gesetzt und bei Hardwareshader im Bereich Open GL steht eine 1.  ::)


Offline Düssel-Jäger

  • Flieger
  • ****
  • Beiträge: 275
Lebst du auch noch!?

Achja,falls dein ReVi nur halb zu sehen ist dann lass mich dir einen Tipp geben.Shift+F1 wirkt Wunder. :P

Grüsse Düssel

Offline Waggelchen

  • Hallenfeger
  • **
  • Beiträge: 29
Lebst du auch noch!?

Achja,falls dein ReVi nur halb zu sehen ist dann lass mich dir einen Tipp geben.Shift+F1 wirkt Wunder. :P

Grüsse Düssel

 :-*